Регистрация |  Правила Форума | Как разместить объявление? Хостинг обеспечен IQHost.ru и VPSVille.ru | uptime: 14 лет 1 месяц 9 дней| всего репутации: +380614.52 
Как разместить объявление?
 ФотогалереяФотогалерея   Слежу за темойСлежу за темой   ПоискПоиск    Пользователи   ПрофильПрофиль   Войти и проверить личные сообщенияВойти и проверить личные сообщения   ВходВход 

Как правильно настраивать ip flow egress





Все новые темы тут
Начать новую тему   Ответить на тему    Список форумов SYSAdmins.RU -> CISCO
Предыдущая тема :: Следующая тема  
Автор Сообщение
Pr. Moriarty
Участник форума



Зарегистрирован: 23.09.2004
Пользователь #: 20,961
Сообщения: 143

Репутация: 87.7Репутация: 87.7 Добавь репутацию, если тебе помоглиСними репутацию если пользователь неадекватен

СообщениеДобавлено: Пн 03 Апр, 2006 16:34    Заголовок сообщения: Как правильно настраивать ip flow egress Добавить пользователя в список игнора Ответить с цитатой

И у кого нибудь это работает .
Вот мой конфиг (часть)
version 12.3
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service dhcp
!
hostname neorouter
!
boot-start-marker
boot system flash c3825-adventerprisek9-mz.123-11.XL.bin
boot-end-marker
!
logging buffered 51200 warnings
no logging console
!
username xxx privilege 15 secret 5 xxx
clock timezone UTC 4
no network-clock-participate slot 1
voice-card 1
dspfarm
!
no aaa new-model
ip subnet-zero
no ip source-route
ip cef
!
no ip bootp server
no ip domain lookup
ip domain name xxx.ru
ip ips po max-events 100
ip accounting-threshold 32768
ip rcmd rsh-enable
ip rcmd remote-host traffic 192.168.xx.xx root enable 8
no ftp-server write-enable
isdn switch-type primary-net5
!
!
interface Null0
no ip unreachables
!
interface Multilink1
ip address 193.x.x.x 255.255.255.252
ip nat outside
ip virtual-reassembly
ip route-cache policy
no cdp enable
ppp multilink
ppp multilink group 1
!
interface MFR1
no ip address
!
interface GigabitEthernet0/0
description int_for_netflow_export
ip address 193.x.x.x 255.255.255.252
ip access-group 110 in
ip access-group 111 out
no ip redirects
no ip unreachables
no ip proxy-arp
duplex auto
speed auto
media-type rj45
no cdp enable
!
interface GigabitEthernet0/1
ip address 192.168.14.1 255.255.255.240
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
ip route-cache policy
ip policy route-map ISP
duplex auto
speed auto
media-type rj45
no cdp enable
!
interface FastEthernet0/2/0
switchport access vlan 10
no ip address
no cdp enable
!
interface Serial0/0/0
bandwidth 2048
no ip address
no ip proxy-arp
encapsulation ppp
no cdp enable
ppp multilink
ppp multilink group 1
!
interface Serial0/1/0
bandwidth 2048
no ip address
no ip proxy-arp
encapsulation ppp
no cdp enable
ppp multilink
ppp multilink group 1
!
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 88.xx.xx.xx 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip route-cache policy
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 193.x.x.x
ip route 0.0.0.0 0.0.0.0 88.x.x.x
ip route 192.168.0.0 255.255.0.0 192.168.14.2
!
ip flow-export version 5
ip flow-export destination 193.x.x.x 7223
!
no ip http server
ip nat pool TETRA x.x.x.65 x.x.x.70 netmask 255.255.255.248
ip nat inside source route-map TETRA-NAT pool TETRA overload
ip nat inside source route-map VT-NAT interface Vlan10 overload
ip nat inside source static 192.168.27.21 xx.xxx.xxx.xxx extendable
ip nat inside source static 192.168.35.7 xx.xxx.xxx.xxx extendable

!
access-list 10 permit 192.168.25.25
access-list 10 permit 192.168.23.5
access-list 10 permit 192.168.23.3
access-list 10 permit 192.168.20.1
access-list 10 permit 192.168.23.2
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.27.0 0.0.0.255
access-list 10 permit 192.168.28.0 0.0.0.255
access-list 10 permit 192.168.30.0 0.0.0.255
access-list 10 permit 192.168.34.0 0.0.0.255
access-list 10 permit 192.168.35.0 0.0.0.255
access-list 10 permit 192.168.36.0 0.0.0.255
access-list 20 permit 192.168.31.0 0.0.0.255
access-list 20 permit 192.168.32.0 0.0.0.255
access-list 20 permit 192.168.33.0 0.0.0.255
access-list 20 permit 192.168.37.0 0.0.0.255
access-list 20 permit 192.168.29.0 0.0.0.255
access-list 100 remark VTY Access ACL
access-list 100 remark VTY Access ACL
access-list 101 deny ip host 192.168.36.11 any
access-list 101 permit ip any any

!
route-map TETRA-NAT permit 10
match ip address 10
match interface Multilink1
!
route-map ISP permit 10
match ip address 10
set ip next-hop xx.xx.xx.xx
!
route-map ISP permit 20
match ip address 20
set ip next-hop xx.xx.xx.xx
!
route-map VT-NAT permit 10
match ip address 20
match interface Vlan10

Настраиваю на inside интерфейсе
ip flow ingress
ip flow egress
Пингую что нибудь - вроде как всё красиво
neorouter#sh ip cache flow | include 192.168.1.12
Mu1 195.128.128.1 Gi0/1* 192.168.1.12 01 0000 0000 6
Gi0/1 192.168.1.12 Mu1 195.128.128.1 01 0000 0800 6
Но вот что попадает в базу(lanbilling) типо этого
inet_ntoa(ip) | cin | cout | timefrom | inet_ntoa(remote)
| 192.168.33.6 | 44 | 1831 | 2006-04-03 17:29:23 | 72.36.169.26 |
| 192.168.36.55 | 0 | 1576 | 2006-04-03 17:29:23 | 212.58.226.19 |
| 192.168.32.5 | 0 | 448 | 2006-04-03 17:29:23 | 64.12.163.132 |
| 192.168.28.2 | 44 | 1988 | 2006-04-03 17:29:23 | 195.5.154.155 |
Вобщем что то тупит нетфлоу , я проверял ethereal-ом именно
это и приходит . Входящие особенно .

_________________
Деньги-зло.Для дополнительной информации вышлите мне 10 $.
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
Pr. Moriarty
Участник форума



Зарегистрирован: 23.09.2004
Пользователь #: 20,961
Сообщения: 143

Репутация: 87.7Репутация: 87.7 Добавь репутацию, если тебе помоглиСними репутацию если пользователь неадекватен

СообщениеДобавлено: Пн 03 Апр, 2006 17:06    Заголовок сообщения: Добавить пользователя в список игнора Ответить с цитатой

Я так думаю что цису сильно корявит из-за route-map на inside интерфейсе (у меня 2 провайдера) .
_________________
Деньги-зло.Для дополнительной информации вышлите мне 10 $.
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
Pr. Moriarty
Участник форума



Зарегистрирован: 23.09.2004
Пользователь #: 20,961
Сообщения: 143

Репутация: 87.7Репутация: 87.7 Добавь репутацию, если тебе помоглиСними репутацию если пользователь неадекватен

СообщениеДобавлено: Ср 05 Апр, 2006 11:10    Заголовок сообщения: Добавить пользователя в список игнора Ответить с цитатой

Всё работает на 12.4(6)Т
На инсайд
ip flow ingress
ip flow egress
На 12.3(11)Т хоть и заявленно - работает криво

_________________
Деньги-зло.Для дополнительной информации вышлите мне 10 $.
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
Показать сообщения:   
Предыдущая тема :: Следующая тема  
Начать новую тему   Ответить на тему    Список форумов SYSAdmins.RU -> CISCO Часовой пояс: GMT + 4


Страница 1 из 1
Перейти:  
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
Вы не можете добавлять приложения в этом форуме
Вы можете скачивать файлы в этом форуме

Пишите нам!
Архитектурная мастерская.
liveinternet.ru: показано число просмотров за 24 часа, посетителей за 24 часа и за сегодня
Яндекс.Метрика



Page generation time: 0.0472s (PHP: 49% - SQL: 51%) - SQL queries: 26 - GZIP disabled - Debug off